Le bug GoG de "libcrypto.so.1.0.0 missing"

Ce bug est parmi l'un des pires (et un des seuls) que j'ai rencontré avec les jeux GoG natif GNU/Linux. Une fois le jeu installé, on lance le start.sh et on obtient ça :

./runner: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory

Le problème est que les jeux ayant ce bug ont besoin d'une librairie obsolète pour fonctionner (libssl1.0.0), cette librairie n'est plus disponible sur la plupart des dépots depuis longtemps maintenant, mais les jeux ne sont pas mis à jour. La solution est d'installer la librairie à la main, en version i386 (32 bits, c'est important, la 64 ne fonctionnera pas). Voilà les étapes à suivre (pour Debian, je n'ai pas tester d'autres distro) :

  1. Télécharger le paquet ici (c'est la version i386)
  2. Lancer la commande en root "dpkg -i libssl1.0.0_1.0.1t-1+deb8u11_i386.deb"

Voilà, c'est très simple mais il faut tout de même le savoir.

Le 13 Thermidor 227

Licence Creative Commons

Accueil Retour